checkout service degradation
Incident Report for Banked
Postmortem

On June 2nd, 2023 at 11:36 UTC, Banked experienced an issue with status updates of payments. The issue was resolved within 45 minutes, at 12:21 UTC on June 2nd.

During this time, successful payments remained in pending status, and merchants did not receive success webhooks until the issue was resolved.

This issue occurred due to an unexpected failure of an application to receive events during routine maintenance of an infrastructure component.

After being alerted, our on-call team initiated a manual recovery procedure to recover the affected application.

Moving forward, we are working to improve the resilience of our applications and their self-healing abilities.

Posted Jun 05, 2023 - 17:41 UTC

Resolved
This incident has been resolved.
Posted Jun 02, 2023 - 12:23 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 02, 2023 - 12:22 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 02, 2023 - 12:22 UTC
Investigating
We are currently experiencing a performance degradation in the checkout service. Payment are processed but status updates are not being sent to customers.

Investigations are ongoing and an update will be provided as soon as more information becomes available.
Posted Jun 02, 2023 - 12:05 UTC
This incident affected: Global (API, Checkout).