Payments failing
Incident Report for Banked
Resolved
This incident has been resolved.
Posted Jan 20, 2023 - 09:49 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 20, 2023 - 09:39 UTC
Investigating
Currently investigating, this is an internal issue and a fix has been identified
Posted Jan 20, 2023 - 09:36 UTC
This incident affected: Global (Checkout).