HSBC Business are currently experiencing a service outage affecting faster payments
Incident Report for Banked
Resolved
This incident has been resolved.
Posted Sep 11, 2020 - 08:43 UTC
Update
All service are now restored
Posted Sep 11, 2020 - 08:41 UTC
Investigating
We are currently investigating this issue.
Posted Sep 10, 2020 - 13:52 UTC
This incident affected: Banks (HSBC Business).