Nationwide outage
Incident Report for Banked
Resolved
This incident has been resolved.
Posted Apr 21, 2020 - 08:30 UTC
Update
We are continuing to investigate this issue.
Posted Apr 21, 2020 - 08:30 UTC
Investigating
We are currently investigating this issue.
Posted Apr 21, 2020 - 08:02 UTC
This incident affected: Banks (Nationwide).