Revolut checkout errors
Incident Report for Banked
Resolved
This incident has been resolved.
Posted Mar 11, 2020 - 13:43 UTC
Investigating
Revolut current checkout api is experiencing problems
Posted Mar 02, 2020 - 14:54 UTC
This incident affected: Banks (Revolut).