EU Payments Issue
Incident Report for Banked
Postmortem

On June 10th, 2024, from 06:30 to 07:20 UTC, Banked experienced a partial outage in the Payments API and Checkout product in the UK/EU region.

During the outage, approximately half of the payment creation and checkout attempts failed.

This problem arose from a failure in one of the infrastructure components managed by our cloud provider. The service was restored after 50 minutes, and our system returned to normal.

We are collaborating with our cloud service provider to prevent such issues in the future.

Posted Jun 10, 2024 - 19:12 UTC

Resolved
This incident has been resolved.
Posted Jun 10, 2024 - 07:43 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 10, 2024 - 07:28 UTC
Update
We are continuing to investigate this issue.
Posted Jun 10, 2024 - 07:22 UTC
Update
We are still investigating, issues are caused by high latency in our Europe data center.
Posted Jun 10, 2024 - 07:19 UTC
Update
We are continuing to investigate this issue.
Posted Jun 10, 2024 - 07:18 UTC
Update
We are continuing to investigate this issue.
Posted Jun 10, 2024 - 06:47 UTC
Investigating
We are currently investigating this issue.
Posted Jun 10, 2024 - 06:44 UTC
This incident affected: EU Payments (Checkout) and UK Payments (Checkout).