API and checkout service degradation
Incident Report for Banked
Postmortem

On September 6th, 2023 between 9:05 -9:25 UTC, Banked experienced an outage in the payments API and checkout product.

During the outage, attempts to create payments failed.

This issue occurred due to a deployment of one of our services with incorrect configuration.

Our on-call team responded immediately to the failure and rolled back the deployment of the service to restore the system to a healthy state.

We are currently working on adding additional verifications to our services to prevent similar issues from occurring in the future.

Posted Sep 07, 2023 - 17:41 UTC

Resolved
This incident has been resolved.

Further details will be provided in the postmortem in due course.
Posted Sep 06, 2023 - 09:33 UTC
Update
We are continuing to investigate this issue.
Posted Sep 06, 2023 - 09:32 UTC
Investigating
We are currently experiencing a performance degradation to the API and checkout service.

Investigations are ongoing and an update will be provided as soon as more information becomes available.
Posted Sep 06, 2023 - 09:25 UTC
This incident affected: Global (API, Checkout).